Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2026 - 17:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 22, 2026 - 14:53 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 22, 2026 - 14:53 UTC
Scheduled
We wanted to let you know that scheduled maintenance will be performed by our authentication provider on Monday 4th May from 5pm - 6pm UTC. To assist you in planning, we have listed the maintenance times in multiple timezones below:
AEST (e.g. Sydney): 3am - 4am, 5th May BST (e.g. London): 6pm - 7pm, 4th May EDT (e.g. New York): 1pm - 2pm, 4th May PDT (e.g. Vancouver): 10am - 11am, 4th May During this time the following actions on the Dashpivot website, Dashpivot app, Sitemate app, Gearbelt and Flowsite website may not be available:
Logging in Resetting your password Signing up as a new or invited user If you face an issue, please wait a few minutes and then try again.
Apart from these actions, the Dashpivot website and mobile app, Flowsite, Gearbelt and the Sitemate App will be running as normal.
Posted Apr 22, 2026 - 14:52 UTC
This scheduled maintenance affected: Dashpivot - Web, Dashpivot - API, Sitemate - API, and Flowsite.